- User Mode : 간단한 조회 명령
sw21>
- Privileged Mode : 상세한 조회 명령, 설정 모드로 진입 가능 모드
sw21>en
sw21#
sw21#sh version 운영체제 버전 정보 확인
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA8, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 12-May-06 19:04 by myl
cisco WS-C2950C-24 (RC32300) processor (revision E0) with 19959K bytes of memory
.
Processor board ID FHK0631Z0NK
Last reset from system-reset
Running Enhanced Image
26 FastEthernet/IEEE 802.3 interface(s)
32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0A:8A:A3:F8:80 : 장비 MAC Address
Motherboard assembly number: 73-5750-10
Power supply part number: 34-0965-01
Motherboard serial number: FOC06300PEU
Power supply serial number: PHI06250AMV
Model revision number: E0
Motherboard revision number: B0
Model number: WS-C2950C-24
System serial number: FHK0631Z0NK
sw21#sh int status 인터페이스별 설정 내용을 확인할 수 있음
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 notconnect 1 auto auto 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
설정 모드 (Configuration Mode)
- Global Configuration Mode : 일반적인 설정, 장비의 이름, 패스워드 등을 설정
(config)#
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#int fa0/11
sw21(config-if)#speed 100
sw21(config-if)#duplex full
sw21(config-if)#end
sw21#
00:40:07: %SYS-5-CONFIG_I: Configured from console by console
sw21#sh int status
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/11 notconnect 1 full 100 10/100BaseTX
Fa0/12 notconnect 1 auto auto 10/100BaseTX
sw21#sh run 현재 스위치에서 실행되고 있는 설정값에 대한 정보
Building configuration...
Current configuration : 1295 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
interface FastEthernet0/11
speed 100
duplex full
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#enable password 1234
sw21(config)#enable secret cisco
sw21(config)#line console 0
sw21(config-line)#login
sw21(config-line)#password superman
sw21(config-line)#exit
sw21(config)#line vty 0 4
sw21(config-line)#login
sw21(config-line)#password sunstar
sw21(config-line)#exit
sw21(config)#exit
sw21#sh run
Building configuration...
Current configuration : 1391 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
enable secret 5 $1$/y9/$wpOEp5Eaxia484kVIpMtq/
enable password 1234
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/11
speed 100
duplex full
!
interface FastEthernet0/12
interface Vlan1
ip address 200.1.2.2 255.255.255.128
no ip route-cache
!
ip http server
!
line con 0
password superman
login
line vty 0 4
password sunstar
login
line vty 5 15
password cisco
login
!
!
end
show ip interface brief
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#no enable password
sw21(config)#no enable secret
sw21(config)#line console 0
sw21(config-line)#login
sw21(config-line)#no password
sw21(config-line)#line vty 0 4
sw21(config-line)#login
sw21(config-line)#no password
sw21(config-line)#exit
sw21(config)#exit
sw21#sh run
Building configuration...
Current configuration : 1286 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface Vlan1
ip address 200.1.2.2 255.255.255.128
no ip route-cache
!
ip http server
!
line con 0
login
line vty 0 4
login
line vty 5 15
password cisco
login
!
!
end
sw21#? 현재 상태에서 사용 가능한 명령어가 모두 보임
Exec commands:
access-enable Create a temporary Access-List entry
access-template Create a temporary Access-List entry
archive manage archive files
cd Change current directory
clear Reset functions
clock Manage the system clock
cns CNS agents
sw21(config)#s? S로 시작하는 모든 명령어가 보임
scheduler service setup shutdown snmp
snmp-server spanning-tree stackmaker system
sw21#config ? config 명령어 뒤에 나오는 옵션들이 모두 보임
memory Configure from NV memory
network Configure from a TFTP network host
overwrite-network Overwrite NV memory from TFTP network host
terminal Configure from the terminal
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#int fa0/3
sw21(config-if)#duplex ?
auto Enable AUTO duplex configuration
full Force full duplex operation
half Force half-duplex operation
sw21(config-if)#speed ?
10 Force 10 Mbps operation
100 Force 100 Mbps operation
auto Enable AUTO speed configuration
해당IP로 switch port 찾기
show ip arp 로 해당 IP의 mac주소 확인
show mac-address-table address 찾을mac주소입력
sw21>
- Privileged Mode : 상세한 조회 명령, 설정 모드로 진입 가능 모드
sw21>en
sw21#
sw21#sh version 운영체제 버전 정보 확인
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA8, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 12-May-06 19:04 by myl
cisco WS-C2950C-24 (RC32300) processor (revision E0) with 19959K bytes of memory
.
Processor board ID FHK0631Z0NK
Last reset from system-reset
Running Enhanced Image
26 FastEthernet/IEEE 802.3 interface(s)
32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0A:8A:A3:F8:80 : 장비 MAC Address
Motherboard assembly number: 73-5750-10
Power supply part number: 34-0965-01
Motherboard serial number: FOC06300PEU
Power supply serial number: PHI06250AMV
Model revision number: E0
Motherboard revision number: B0
Model number: WS-C2950C-24
System serial number: FHK0631Z0NK
sw21#sh int status 인터페이스별 설정 내용을 확인할 수 있음
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 notconnect 1 auto auto 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
설정 모드 (Configuration Mode)
- Global Configuration Mode : 일반적인 설정, 장비의 이름, 패스워드 등을 설정
(config)#
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#int fa0/11
sw21(config-if)#speed 100
sw21(config-if)#duplex full
sw21(config-if)#end
sw21#
00:40:07: %SYS-5-CONFIG_I: Configured from console by console
sw21#sh int status
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/11 notconnect 1 full 100 10/100BaseTX
Fa0/12 notconnect 1 auto auto 10/100BaseTX
sw21#sh run 현재 스위치에서 실행되고 있는 설정값에 대한 정보
Building configuration...
Current configuration : 1295 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
interface FastEthernet0/11
speed 100
duplex full
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#enable password 1234
sw21(config)#enable secret cisco
sw21(config)#line console 0
sw21(config-line)#login
sw21(config-line)#password superman
sw21(config-line)#exit
sw21(config)#line vty 0 4
sw21(config-line)#login
sw21(config-line)#password sunstar
sw21(config-line)#exit
sw21(config)#exit
sw21#sh run
Building configuration...
Current configuration : 1391 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
enable secret 5 $1$/y9/$wpOEp5Eaxia484kVIpMtq/
enable password 1234
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/11
speed 100
duplex full
!
interface FastEthernet0/12
interface Vlan1
ip address 200.1.2.2 255.255.255.128
no ip route-cache
!
ip http server
!
line con 0
password superman
login
line vty 0 4
password sunstar
login
line vty 5 15
password cisco
login
!
!
end
show ip interface brief
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#no enable password
sw21(config)#no enable secret
sw21(config)#line console 0
sw21(config-line)#login
sw21(config-line)#no password
sw21(config-line)#line vty 0 4
sw21(config-line)#login
sw21(config-line)#no password
sw21(config-line)#exit
sw21(config)#exit
sw21#sh run
Building configuration...
Current configuration : 1286 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw21
!
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface Vlan1
ip address 200.1.2.2 255.255.255.128
no ip route-cache
!
ip http server
!
line con 0
login
line vty 0 4
login
line vty 5 15
password cisco
login
!
!
end
sw21#? 현재 상태에서 사용 가능한 명령어가 모두 보임
Exec commands:
access-enable Create a temporary Access-List entry
access-template Create a temporary Access-List entry
archive manage archive files
cd Change current directory
clear Reset functions
clock Manage the system clock
cns CNS agents
sw21(config)#s? S로 시작하는 모든 명령어가 보임
scheduler service setup shutdown snmp
snmp-server spanning-tree stackmaker system
sw21#config ? config 명령어 뒤에 나오는 옵션들이 모두 보임
memory Configure from NV memory
network Configure from a TFTP network host
overwrite-network Overwrite NV memory from TFTP network host
terminal Configure from the terminal
sw21#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw21(config)#int fa0/3
sw21(config-if)#duplex ?
auto Enable AUTO duplex configuration
full Force full duplex operation
half Force half-duplex operation
sw21(config-if)#speed ?
10 Force 10 Mbps operation
100 Force 100 Mbps operation
auto Enable AUTO speed configuration
해당IP로 switch port 찾기
show ip arp 로 해당 IP의 mac주소 확인
show mac-address-table address 찾을mac주소입력